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Backup and restore your website using SharePoint Designer
If you are playing with the nice functionality in SharePoint, you want to save from time to time the
modifications that you already have been doing on a site. Or you could backup your site before you are
going to make it available for your users.
Again, you can use SharePoint Designer to backup and restore your website.
Start by opening your site in SharePoint designer, and use 'Site' in the menu bar to go to 'Backup website'
in the 'Administration' option:
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Afterwards you can restore your website:
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As the saying goes, its sometimes better to do something yourself than have someone else do it for you.
The same is true for the Central Admin site as there are always some issues with some functions and I just
prefer doing most administrative tasks via stsadm. I found stsadm to be the easiest and simplest way of
doing majority of administrative functions. One of tasks is backing up and restoring SharePoint site
collections.
Browse to SharePoint Directory
1. Launch the command prompt
2. Type cd "%programfiles%\Common Files\Microsoft Shared\web server extensions\12\BIN"
Backup Site Collection
1. Type stsadm -o backup -url <url> -filename <filename>
○ <url> is the url of the site collection that you want to backup
○ <filename> is the filename of where to store the site collection
What's Not Included During Backup?
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1. My Sites
2. Sub site collections.
Keep this in mind when doing a backup.
Restore Site Collection
1. Type stsadm -o restore -url <url> -filename <filename> -overwrite
○ <url> is the url of the site collection that you want to restore
○ <filename> is the filename of where to store the site collection
○ overwrite be cautious with this command as you don't want to overwrite the wrong site
collection
Possible Security Error during Restore
Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)).
Now you might possibly have an issue during the site collection restore process. This can happen when
the the account that you used to do the backup was not the site administrator and during your restore
process, it will fail for you. There is a way to fix that in case you are at another location during the restore
process and can not run the backup with the correct user account. What you will notice after the restore
process not working that the Event Viewer will contain information on what user account does not have
access to perform this action.
1. Launch Event View and view the System Events
2. Look for the system will complain about a DECOM event .. starting with: "The application
specific permission settings do not grant local activation for .... with CLSID XXXX ..... to the
user referencing a 'domain name service account'".
3. Make a note of the CLSID as we will need that later on.
4. Goto Administrative Tools -> Component Services
5. Click on Component Services and then Computers and then My Computer (depending on your
computer name)
6. Click on DCOM Config and change the view to show the items in Details view
7. Look for the item that matches your CLSID
8. Right click on the item that matches the CLSID and click on Properties
9. Select the Security tab
10. Click edit next to Customize under the Launch and Permissions section
11. You will notice that the user that you were trying to run the command is not part of the security
listing
12. Add the user and reboot the system
Creating a Backup in SharePoint Designer (CMP File)
Sites Less Than 25 MB
1. Go to File then Open Site and enter your SharePoint Site Address (like http://your-wss-site.com)
and use your "WSSAdmin" user to connect.
2. Once connected, go to Site, then Administration and finally Backup Web Site.
3. Enter an existing directory on your site as a backup location, and enter a location on your
computer to save your files locally.
Sites More Than 25 MB
Because of a bug with SharePoint Designer, if your site is more than 25 MB when backed up you will not
be able to use that backup to restore your site later. The backup needs to be less than 25 MB.
You will have to backup individual documents and uploaded files to computer and delete them from your
site to bring your site to less than 25 MB. Once the size of the site is down below 25 MB, use the steps
above to backup your site.
Exporting a site as a Personal Web Package (FWP File)
There is also an option in SharePoint Designer to Export site as a Personal Web Package (.fwp file). From
the File menu select Export and then Personal Web Package.
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Please note that this will not backup all aspects of your site, including list data, sub-sites, or security and
permissions settings. The Personal Web Package can be used to export uploaded files and documents, but
may not be reliable when restoring full pages. Generally this method is recommended only for restoring
only a site template.
Restoring a Backup using SharePoint Designer
If you are restoring a backup to a new sub-web created using SharePoint Designer, you can follow these
steps:
1. Connect to your site with SharePoint Designer by going to the File menu, selecting Open Site
and entering your site address (like http://your-wss-site.com). When prompted log in using your
"WSSAadmin" user to authenticate.
2. Go to File, then New, and finally Web Site.
3. Select "General".
4. Select "Empty Web Site".
5. At the bottom of the window, enter your SharePoint site address with the new directory for subsite (like http://your-wss-site.com/sub-web/). This must be a new directory, and not an existing
sub-web.
6. Click "OK".
7. Use steps below to restore your site.
If you are restoring a backup to a new sub-site created from your SharePoint web site, you can follow
these steps to create the site:
1. Connect to SharePoint Site in a web browser.
2. Go to Site Actions, then Site Settings, and finally Sites and Workspaces.
3. Click Create.
4. Select Blank Site as the template. If you use any other templates you may receive an error when
trying to complete the restoration.
And then restore your site by following these steps:
1. If you are restoring a full site, make sure to sign up using the Blank Site template. Any other
templates may give an error when trying to restore.
2. Connect to your new site, or recently created sub-web, from SharePoint Designer.
3. Go to Site, then Administration, and then Restore Web Site.
4. Select your locally saved copy of your backup and Restore it to the server.

Backup and Restore Sharepoint Site
BACKUP SITE COLLECTION
Instruction to use the stsadm command line tool.
TO EXPORT
To back up a site or subsite by using the Stsadm command-line tool
You can use the export operation to save
a site or subsite. You can then use the import
operation to import the site or subsite to the same or another server at a later time. Although using the
export operation saves data for you, it is not the same as using the backup operation. You cannot
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save a workflow, alerts, features, solutions, or Recycle-Bin state by using the export
operation. If you want a full-fidelity backup, use the backup operation to back up the site
collection as described in the "Back up
a site
by using the Stsadm command-line tool" procedure earlier in this article.

collection

Backup
a site or subsite by using the Stsadm command-line tool
1.
On the drive on which SharePoint Products and Technologies is installed, change to the following
directory: %COMMONPROGRAMFILES%Microsoft sharedWeb server extensions12Bin.
2. Type the following command:
stsadm -o export -url <URL name> -filename <export file name>
where URL name is the URL of the site or subsite that you want to back up, and where export file name is
the name of the export file.
3.
If the export completes successfully, the command window displays the following text:
Copy Code
Operation completed successfully.
4.
If there are errors or warnings, or if the export does not complete successfully, see the export file
name.export.log file for the file that you specified in step 2.
TO IMPORT

To restore

a site or subsite by using the Stsadm command-line tool

You can use the export operation to
save
a site or subsite. You can then
use the import operation to import the site or subsite to the same or another server at a later time.
Restore
a site or subsite by using the Stsadm command-line tool
1.
On the drive where SharePoint Products and Technologies is installed, change to the following
directory: %COMMONPROGRAMFILES%Microsoft sharedWeb server extensions12Bin.
2. To import
a site or a subsite, type the following command, and then press ENTER:
stsadm -o import -url <URL name> -filename <import file name>
where URL name is the URL of the site or subsite that you want to import and import file name is the
UNC path and file name of the file that you want to import — for example, backupshareimport.cmp.
3.
If the import completes successfully, the command
window displays the following
text:
Copy Code
Operation completed successfully.
4.
If there are errors or warnings, or if the import does not complete successfully, see the import file
name.import.log file for the file that you specified in step 2.
BACKUP SHAREPOINT SUBSITES
To backup individual subsite you should use Sharepoint Desinger.
Here is a link give you detail instruction on how to backup a sub site on sharepoint designer.
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http://office.microsoft.com/en-us/sharepointdesigner/HA100699391033.aspx
FAQ
* Where to look when backup or restore failed?
A: Look in spbackup.log
* Difference between new and overwrite option?
A: Use new option when you want
etc, and use overwrite
* Access right for

to restore to a different farm or a new server, database
to restore over old database.
backup and restore

A: You will need to be Farm administrator to perform

backup and restore

Backing Up Sharepoint Sites
Wednesday, August 06, 2008 11:48 AM
There are three ways of backing up Sharepoint sites, which one you use depends on which site/subsite
you are backing up and what you intend to do with the backup.
1. stsadm backup
2. Sharepoint Designer backup
3. stsadm export
1. stsadm -o backup and stsadm -o restore
This can only be performed from the server itself and only allows you to backup from the top level site
downwards, however, it allows you to essentially clone the site collection along with preserving all
metadata, user rights. Ideal for disaster recovery purposes.
To backup:
1. On the server locate the file stsadm.exe (should be in \Program Files\Common Files\Microsoft
Shared\web server extensions\12\BIN),
Tip: Add the path to the stsadm.exe file into the environment variable path for the server, saves a whole
lot of typing!
2. From a command prompt, type [path to stsadm.exe\]stsadm -o backup -url http://[url-of-the-website] -filename [path\filename.dat]
To restore:
1. Create a web application (but don't create a site collection)
2. From a command prompt, type [path to stsadm.exe\]stsadm -o restore -filename
[path\filename.dat] -url http://[url-of-the-web-site]
2. Sharepoint Designer Backup
This backup method is ideal for moving inidividual sites and subsites around within a site collection as
well as migrating them from one server to another. You only need administrative rights to the site/subsite
rather than access to the actual server. The main issue with a Designer backup is the loss of
created/modified metadata along with Sharepoint Designer created custom data-view web-parts. Another
major problem with Sharepoint Designer backups is the 25MB limit which makes Designer backups not a
whole lot of use once the site is in use.
To backup:
1. Open the site with SharePoint Designer
2. Select Menu Site > Administration > Backup web site
3. On the next screen, you can check the box to include subsites in the backup
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4. Unless your current website is low on disk space, leave the temporary location where it is and choose
where to save the final .cmp file.
To restore:
1. Open the site above where the restored site will be using Sharepoint Designer
2. From the File menu go New > Website
3. From the website templates, choose the Empty Web Site template
4. In the 'Specify the location of the new website' box type the path to the new site.
5. From the Site menu select Administration > Restore Website
6. Select the .cmp file and click Open.
3. stsadm -o export and stsadm -o import
This type of backup has similar uses to the Sharepoint Designer backups (loss of some metadata and webpart data-views), however this method avoids the 25MB site limit. The other smallish issue is you need
access to the server.
To export a site:
1. On the server locate the file stsadm.exe (should be in \Program Files\Common Files\Microsoft
Shared\web server extensions\12\BIN),
2. At a command prompt type [path to stsadm.exe\]stsadm -o export -url http://[url-of-the-website/subsite] -filename [path\filename.dat]
If you include the -includesecurity switch, then the security settings and site owner information is
retained, otherwise the site owner becomes whoever performs the import.
To import a site:
1. Create a web application and a site collection using sharepoint central administration if they don't
already exist. Or you can create a subsite in an existing site collection, either way use the "Blank site"
template.
Caution: Watch out here for subsites you included in the export, you will need to create blank versions of
those as well otherwise the import will fail. Check the spelling of the url rather than the site name, they
do need to be exactly the same.
2. At a Command prompt type stsadm -o import -url http://[url-of-the-web-site/subsite] -filename
[path\filename.dat]

Add Icons for Unknown File Types for the SharePoint Document Library
Tuesday, April 29 2008 @ 11:11 PM MDT
Contributed by: admin
Views:: 740
If you added a new document type to sharepoint 2007 and that file type is not already specify in
Sharepoint you get a default icon for that file type. For example to add in a .xla document type you will
get a default icon for this file type.
Here are the step to add or modify the icon for the new file type.
1. Go the your sharepoint server
2. Go in open up the this file C:Program FilesCommon FilesMicrosoft Sharedweb server
extensions12TEMPLATEXMLDOCICON.XML.
3. Search for ByExtension
4. In this example we will try to add in the xla file type. Add in <Mapping Key="xla"
Value="XLA16.GIF"/>
5. Ensure this icon file is in C:Program FilesCommon FilesMicrosoft Sharedweb server
extensions12TEMPLATEIMAGES
6. You will need to restart Internet Informatin Services (IIS) for the change to take effect.
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